job.answiz.com
  • 1
Votes
name

I am working through NativeScript's set-up on OS X El Capitan and I am stuck at the point where I am supposed to install xcodeproj and cocoapods. Almost everything that I try to do with gemshows the same error:

$ sudo gem install xcodeproj
ERROR:  While executing gem ... (Errno::EINVAL)
    Invalid argument

The following commands show the same error, wether I run it with sudo or not:

$ gem update --system
$ gem update
$ gem install whatever
$ gem install cocoapods

I have the following versions:

$ ruby --version
ruby 2.3.1p112 (2016-04-26 revision 54768) [x86_64-darwin15]

$ gem --version
2.6.7

I've tried some of the help that I've found online, including reinstalling gem and ruby, restarting but nothing has helped.

I guess that I have a configuration problem with Ruby.

Any suggestions on how to troubleshoot this?

I just had a similar issue after updating everything via Homebrew.

I solved the issue by uninstalling Ruby and installing it via rbenv, then reinstalling cocoa pods.

Steps:

  1. Uninstall ruby

    brew uninstall ruby

  2. Install rbenv and ruby-build

    brew install rbenv ruby-build

  3. You need to add Ruby to your path.

    A. If Terminal is your shell.

    Add eval "$(rbenv init -)" to ~/.bash_profile

    B. Or if you use another shell

    You can find the instruction by entering the command rbenv init NAME_OF_YOUR_SHELL.

  4. Install Ruby

    rbenv install 2.3.1

  5. Set the Ruby version

    rbenv global 2.3.1

    rbenv local 2.3.1

  6. Reinstall Cocoapods

    gem install cocoapods

  • 0
Reply Report