job.answiz.com
  • 4
Votes
name

After upgrade from Ubuntu 17.10 to 18.04 the bootprocess takes 30s longer than before.

it stops for 30 seconds at the step

Begin: Running /scripts/local-premount

Then it continues.

At first it continued one step further to

scanning for btrfs file systems

so I uninstalled btrfs support, but that didn't help with the problem.

I see no notice of that step neither in dmesg nor in var/log/boot.log

How can I debug this problem? Can I enable additional logging?

 

Try the following:

  • open /etc/initramfs-tools/conf.d/resume
  • replace RESUME=UUID=xxx with RESUME=none
  • issue sudo update-initramfs -u
  • reboot your system

The file should contain the UUID of your swap partition, you can check this with sudo blkid | grep swap.

I found the following bug on launchpad which is supposed to be Lubuntu specific but the commands above also resolved the same issue on my Xubuntu installation.

See comments #27 and #28.

This file seems to be related to hibernate/suspend, I can confirm suspend still works on my system after the changes.

  • 0
Reply Report