job.answiz.com
  • 126
Votes
name

I have been running MAMP Pro 3.05 successfully in Yosemite up to DP4 on a partition that was a clean install of Yosemite.

I now have run the installer for DP5 over my Mavericks install, and now that MAMP Pro install will not start Apache. It says to check the logs, but I don't see anything pertinent.

I'm assuming that since this is a pre-existing install, something in its config is wrong for Yosemite's Apache.

I got MAMP v3.4 working.

I renamed "envars_" to "_envars" ... but that didn't work.

I had to also go into preferences, and hit the "Set Web & MySql ports to 80 & 3306" button!

Works!

  • 0
Reply Report

I was running MAMP 3.0.5 on Mavericks. After upgrading Mavericks to El Capitan, I ran into the same issue. Mysql did start normally but Apache did not.

After renaming envvars to _envvars in the folder /Applications/MAMP/Library/bin such as suggested for Yosemite, I was able to start Apache as before.

So, this fix works for El Capitan as well!

  • 0
Reply Report
name
  • 0

Today, I upgraded to MAMP Pro 3.0.7.3 after I upgraded to OSX Yosemite 10.10 (official release) and I experienced this same problem. Apache could not start and it has an empty log file.

I tried this fix, but I noticed that the file is named "envvars_" not "envvars". I renamed it to envvars, restarted MAMP Pro and apache could not start and it had an empty log file. I also noticed that the envvars file had been renamed to envvars_ after I had renamed it.

  • 0
Reply Report

MAMP Pro 3.0.7.3 should run fine on Yosemite, but after installing it on a brand new machine, I experienced the same problem.

In my case, the problem occurred because I had defined Additional Parameters for my virtual host that contained quotes. By default, Yosemite keyboard settings are set to convert straight quotes to smart quotes ("no-cache" became “no-cache”. Depending on font and font size, this may not be immediately obvious). This made Apache crash, even when the host was disabled.

To change this settings, go to System Preferences -> Keyboard. In the Text tab, uncheck Use smarts quotes and dashes.

  • 0
Reply Report

Just found workaround from MAMP on Twitter

Workaround for the 10.10 Preview 5 bug: Rename the file “envvars” located in into “_envvars”

  • 3
Reply Report